ESX-VMWare – Nach SSL konfiguration im IIS7 unter Windows Server 2008 funktionieren VMWare-Tools nicht mehr

Ich habe eine virtuelle Maschine die auf einem ESX 3.5 läuft, in dieser virtuellen Maschine läuft ein IIS7 mit Windows Server 2008.
Nachdem ich ein Website mit einem SSL-Zertifikat ausgestattet habe, habe ich den Server neugestartet und dann ging nix mehr!

Die VMWare-Tools liefen nicht mehr und auch etliche Dienste starten nicht mehr und ließen sich auch nicht nachträglich starten. Mehrere Neustarts änderten dies nicht, erst dachte ich es war ein Windows Update das mir den Server zerstörte dem war aber nicht so. Da ich auch dies ausschliessen wollte, erstellte ich eine neue virtuelle Maschine und auch hier nachdem einspielen des SSL-Zertifikats verweigerte dieser seine Arbeit.

Ihr müsst in der Registry folgendes eintragen, neustarten und dann funktioniert der Server wieder:
1. Open Registry Editor
2. Navigate to HKLM\System\CurrentControlSet\Services\HTTP and create the following Multi-string value: DependOnService
3. Double click the new DependOnService value that you created
4. Enter CRYPTSVC in the Value Data field and click OK
5. After you have made this change, you will need to reboot the server.

Quellen:
VMWare-Communtiy
Microsoft

Wie immer auf eigene Gefahr und immer schön Backup machen…

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.