WSS – Neue URL zur Webanwendung hinzufügen

Habt Ihr schon mal einen Windows Sharepoint Server mit Sharepoint-Services aufgesetzt entweder zum testen oder sonstiges und es war vorher noch nicht klar das dieser mal online bzw. produktiv gehen soll und unter einer Domain (wie z.B. http://sharepoint.DOMAINNAME.de) erreichbar sein soll?
Mir gings in letzter Zeit immer öfter so und jedesmal suchte ich mir nen Wolf wo ich das nochmal einstellen musste, sämtliche Literatur durchsucht oder das Internet durchsucht ohne eine wirkliche Hilfe…

Jetzt war es wieder so und ich wusste es wieder nicht mehr, deshalb dachte ich mir schreibs da auf dann weißt es as nächste mal aber warum nur
für mich notieren:

  1. Zentraladministration des Sharepoint öffnen und einloggen
  2. Unter Vorgänge
  3. Alternative Zugriffszuordnungen
    Hier sieht man die URL’s die schon eingerichtet sind und auf welche Webanwendung sie zeigen
  4. „Öffentliche URLs bearbeiten“ klicken
  5. Alternative Zugriffszuordnungssammlung:
    Hier die Webanwendung auswählen die eine weitere URL bekommen soll unter der diese vom Internet erreichbar sein soll
  6. Unter „Internet“ bei „Öffentliche URLs“ die neue URL eintragen und speichern

Wenn Ihr dann auf die URL geht sollte, vorrausgesetzt Ihr habt den DNS richtig eingerichtet, die Webanwendung von dem Sharepoint aufgehen.

Wie immer übernehme ich keine Haftung.

VMWare – ESXi Update/Patch einspielen ohne Update-Tool

 

Wollt Ihr wissen wie man ein Update auf dem ESXi Server einspielt ohne VMWare-Update-Manger, VMWare Infrastructure oder sonstige Tools die es im Internet gibt, ja dann geht’s hier weiter…
Noch eine Anmerkung, ein paar Linux-Kenntnisse sind hier von Vorteil.

  1. SSH für ESXi-Server freischalten wenn es nicht schon freigeschaltet ist.
    Dafür gibt es im Internet Anleitungen, Google hilft hier weiter.
  2. Version herausfinden und Update downloaden
    1. Mit VMWare Infrastructure Client zum ESXi-Server verbinden und Version ablesen
    2. Auf die VMWare Patch Seite gehen und das entsprechende Update herunterladen.
      Wenn Ihr nicht sicher seit, könnt ihr auch das erste nehmen das ist immer ein vollständiges Update das alle früheren und aktuellen Updates enthält.
      Achtung: Bei dem Patch steht immer dabei ob ein Reboot oder ähnliches gemacht werden muss wenn dem so ist müsst Ihr beim Updaten aufpassen weil am Schluß der Server den Reboot von alleine macht. Hierbei werden dann auch alle virtuellen Maschinen heruntergefahren außer Ihr habt zwei Server die im Failover laufen!
  3. Update per SSH, WinSCP, FTP auf den ESXi-Server laden
  4. Zum ESXi-Server verbinden
    1. Entweder von Windows über Putty
    2. Bei Linux einfach über ssh
  5. Update entpacken
    Kommt auf die Dateiendung der Datei an welchen Befehl Ihr dafür verwenden müsst.
    Bei .zip einfach unzip versuchen dann wird es in einen Unterordner in dem Ordner wo Ihr euch befindet entpackt
  6. In den Ordner wechseln in dem jetzt das Update liegt mit z.B. “ cd ESX350-200810201-UG“
  7. Update Befehl eingeben 
    1. Mit automatischen Reboot: # esxupdate update
    2. Ohne automatischen Reboot: # esxupdate update –noreboot
  8. Wenn alles ohne Probleme durchgelaufen ist und Ihr euch wieder mit dem VMWare Infrastructure Client verbunden habt sollte bei der Gesamtübersicht die aktuelle Version stehen.

Alles wie immer ohne Übernahme irgendwelcher Haftung für Fehler.

Der Technic3D-Weihnachts-PC Teil 1

Neuigkeiten von Partnern:

Bei vielen unserer Leser steht zu Weihnachten auch wieder Hardware auf dem Wunschzettel und auch nicht selten soll ein kompletter PC unter dem Christbaum liegen. Hierfür haben wir bereits im letzten Jahr begonnen an den Adventssonntagen Hardware-Konfigurationen in verschiedenen Preisklassen vorzustellen, mit denen wir eine grobe Richtschnur für den Einkauf geben und damit bösen Überraschungen nach den Feiertag vorbeugen wollen. Bewusst empfehlen wir hier keinen fertigen Komplett-PC eines bestimmten Herstellers, sondern zeigen auf was für einen bestimmten Betrag an Hardware erwartet werden darf. Den Anfang möchten wir in diesem Jahr mit einem günstigen Einsteiger-Rechner machen, der sich im Preisrahmen bis ~600€ bewegt.

Link

Plesk-Linux – Nach Plesk-Update auf 8.6.0.4 werden keine Flaggen mehr im AWStats angezeigt

Vor kurzem habe ich auf unseren Web-Servern in der Arbeit das neueste Plesk-Update eingespielt, dann gleich am nächsten Tag der erste Anruf von einem Kunden der es ganz genau nimmt, die Flaggen im AwStats unter „Countries“ fehlen. Nach kurzer Recherche habe ich den Fehler auch schon gefunden Parallels (früher SwSoft) haben dies deaktivert, wegen was auch immer.

In den Configs vom AwStats ist die Zeile

LoadPlugin=“geoip GEOIP_STANDARD /usr/local/share/GeoIP/GeoIP.dat“

auskommentiert, einfach die „#“ entfernen, speichern und den Pfad „/usr/local/share/GeoIP/GeoIP.dat“ überprüfen. Sollte die GeoIP-Datenbank dort nicht liegen müsst Ihr das entsprechende Perl-Modul installieren und die Datenbank downloaden und abspeichern. Das könnt Ihr genauer in der HowTo dazu durchlesen, diese habe ich verwendet.

Wer es nicht erwarten kann, kann auch manuell das generieren der Statistik anstoßen, dafür lt. der Befehl:

/usr/local/psa/admin/sbin/statistics –calculate-one –domain-name=DOMAIN

Link dazu.

Bemerkung: Plesk legt für jede Domain 4 Config-Dateien für AwStats an in allen muß diese Änderungen vorgenommen werden. Unter Linux gibt es dazu genug einfache Möglichkeiten.

Sprüche – ArschlochAmpel und ArschlochRot

NaviDani und flitzender_elch wollen ins Bad fahren und fahren so mit dem Auto dann kommen Sie an eine Ampel und die Ampel schaltet auf Rot ist ja alles halb so wild:

  1. flitzender_elch: „Jetzt ist die Arschlochampel rot!“
  2. NaviDani: “ Hahahaha“
  3. flitzender_elch: „lacht ziemlich laut“
  4. NaviDani: „Jetzt ist die Arschlochampel arschlochrot!“
  5. flitzender_elch + NaviDani: *schmeißen sich im Auto weg*,
    vor lauter lachen vergessen Sie das die Ampel auf arschlochGRÜN steht!

 

Wenn euch mal langweilig ist dann redet mit jemanden und setzt vor jedes Hauptwort „Arschloch“, ihr werdet euch vor lachen bepissen (na wer weiß wo der Spruch herkommt, wer es weiß bekommt von mir nen Keks!).

Windows – Explorer.exe startet nicht oder wird nicht gefunden!

Gestern ruft mich ein Kumpel an und sagt er kann an seinem PC nichts mehr machen, er sieht nach einem Start des PCs nur einen blauen Hintergrund. Ich dachte natürlich sofort an einen Bluescreen, tja geirrt nach einem Neustart und der Anmeldung werden keine Icons und auch die Taskleiste nicht angezeigt!

  1. Lösungsansatz
    -> Taskmanager öffnen
    -> Neuer Task
    -> explorer.exe
    Meldung: „Explorer.exe kann nicht gefunden werden“
  2. Lösungsansatz
    -> Taskmanager öffnen
    -> Neuer Task
    -> %Systemroot%\explorer.exe
    Meldung „Explorer.exe kann nicht gefunden werden“

Seltsam, also boote ich von einer Knoppix-CD lass die Festplatte mounten und schaue nach im Windows-Ordner aber die Explorer.exe ist vorhanden. Noch seltsamer, gut das in der Nähe ein zweiter Rechner mit XP steht die Explorer.exe per Netzwerk und Knoppix auf den fehlerhaften PC kopiert und ersetzt. Gut Neustart selbes Phänomen keine Icons keine Taskleiste!

Kumpel schon am Haareraufen „oh nein PC neuinstallieren, omg!!!“, in dem getuschel spricht er was von einer komischen E-Mail mit Anhang und da kam der AH-Ha-Effekt ein Virus! Also neuer Versuch, Knoppicillin-CD rein und start, alle Anti-Virenscanner updaten und suchen lassen. Die Scanner haben einiges gefunden und auch entfernt.
Dann ein Neustart und… verdammt wieder keine Icons des is ja wirklich zum Haareraufen! Nach einiger Googlezeit ein Thread in einem Forum mit Regedit einen Key überprüfen, wenn der vorhanden ist löschen Neustarten und fertig. Ok ausprobiert Neustart siehe da alles wieder da! Für den mist 2 Stunden gebraucht, damit Ihr nicht so lange braucht hier die Lösung:

  1. Regedit starten
    Start -> ausführen -> Regedit -> enter
    Taskmanager öffnen -> Neuer Task -> Regedit -> Enter
  2. Folgenden Key suchen
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options
  3. Wenn hier ein Ordner mit dem Namen „Explorer.Exe“ auftaucht, diesen löschen
    Den Key evtl. vorher Exportieren, als kleines Backup sozusagen, wenn Ihr wollt natürlich nur. Dann könntet Ihr den Key ggf. wieder importieren wegen was auch immer!
  4. Neustart
  5. Fertig, sollte alles wieder funktionieren.

Bemerkung: Mit dieser Methode könnte man auch Freunde, Kollegen oder Familie ärgern die oft am PC sitzen! Alles natürlich auch auf eigene Gefahr, Haftung übernehme ich für nichts.

Mein Blog

Nach langem hin und her neue Website, neues Layout usw. habe ich mir gedacht, moah da hab ich keinen Bock drauf ja keinen Meter. Viel zu viel Arbeit und viel zu wenig Zeit und keine Lust!
Durch zu Fall in der Arbeit ein neuer Hosting-Auftrag für ne Website mit WordPress zum bloggen bei kurzer Durchsicht dachte ich mir das kann ich ja auch machen und ist mit nicht soviel drumrum genau das Richtige.

Also hier mein Blog jetzt kann ich das Internet auch mit meinem gesülze füllen 😉

Alles was mir so in der IT über den Weg läuft!